check_netapp_node

Checks the uptime (time since last reboot) and the NetApp-filers Ontap version.

Description

This plugin has subcommands. Depending on the subcommand an other aspect of the nodes are checked.

  • uptime: Checks the time since the last nodes restart.

  • version: Checks the Ontap version running on each node.

Thresholds

For both subcommands thresholds can be set.

The uptime subcommand understands the --comparison option. This allows to check for either overly-long or overly-short uptimes.

In case of the version subcommand, the thresholds must be given in a semver-compatible format. See https://github.com/Masterminds/semver#basic-comparisons for details. In case of the older format generation.major (e.g. 9.8) a minor-version of 0 (e.g. 9.8.0) is assumed.

The Semver syntax is quite tolerant, e.g. a version like 910.1 would be accepted and considered as what it is: Generation 910, Major 1 - even though you obviously just forgot the dot between the first two digits (which would change the meaning to Generation 9, Major 10, Minor 1 ). This could easily lead to false negatives. So take extra care when setting the thresholds!

Patch-levels should not have leading zeros. E.g. these two versions are not the same: 1.2.3-041.2.3-4.

Including and excluding

The pattern or string given to the --exclude|-X and --include|-I parameters is matched against the instances full-name which includes the node name. This allows to check specific nodes only (or to exclude some of them).

Examples

Simple Examples

$ check_netapp_node uptime -H filer

Checks the uptime of all nodes.


./check_netapp_node version -H filer           
NETAPP_PRO VERSION OK - 1 node checked
na-01.AFF8040: 9.8.0-15 (NetApp Release 9.8P15: Wed Nov 23 09:29:16 UTC 2022, model: AFF8040)

Displays the Ontap version of all nodes. The semver-incompatible format 9.8P15 is translated to 9.8.0-15. This format is then valid for the thresholds.


./check_netapp_node version -H filer --critical=<9.8.0-16
NETAPP_PRO VERSION CRITICAL - 1 node checked
na-01.AFF8040: 9.8.0-15 (NetApp Release 9.8P15: Wed Nov 23 09:29:16 UTC 2022, model: AFF8040)

Checks for Ontap versions below 9.8P16 on all nodes - 9.8P15 is smaller and therefore critical.


Checking for a list of versions

./check_netapp_node version -H filer --warning=9.10.1-9 || 9.10.1-11
NETAPP_PRO VERSION WARNING - 2 nodes checked, 2 WARNING
na2-02.FAS2750: 9.10.1-9 (NetApp Release 9.10.1P9: Thu Nov 03 23:29:00 UTC 2022, model: FAS2750)
na2-01.FAS2750: 9.10.1-9 (NetApp Release 9.10.1P9: Thu Nov 03 23:29:00 UTC 2022, model: FAS2750)

Warns when one of two versions is found. This list can also be longer and could include any version (or range for versions) you think is faulty or unsuitable for your environment.